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Compartment Level Survey Mapping Forms and Dashboard 

A web-based platform for forest data management in Punjab, enabling Assistant Directors (ADs), QA Leads, QC 

Persons, and District Forest Officers (DFOs) to collect, validate, and monitor spatial/non-spatial forest data. 

Key Modules: 

Assistant Directors (ADs) 

• Collect field data (spatial/non-spatial). 

• Edit datasets/compartments. 

• Mark forests as "Completed" after full survey. 

• Correct data returned from QC/DFO. 

 

QA Leads 

• Assign forests to QC team members for review. 

• Monitor QC progress. 

 

QC Persons 

• Analyze spatial/non-spatial data of compartments. 

• Flag errors or return data to ADs for corrections. 

 

District Forest Officers (DFOs) 

• View forest-level summaries (tabular + map). 

• Inspect boundaries/compartments with interactive popups. 

• Raise observed issues on each compartment. 

 

Sign In / Login 

Step 1: Access the Login Page 

• Open your web browser and navigate to the URL. 

• The Login screen will appear (as shown below): 

 

 

Step 2: Enter Credentials 

• Username: Enter your assigned username (e.g., AD_Lahore01, QC_User42). 

• Password: Type your password (case-sensitive). 

 

Step 3: Sign In 

• Click the "LOGIN" button. 

 

If credentials are correct, you will be redirected to your role-specific welcome page. 

Troubleshooting: 

 



 

 

  Invalid Credentials: Ensure caps lock is off and retry. Contact admin if issues persist. 

Login Screen Overview 

 

 

Assistant Director (AD) Module 

This is the landing page for Assistant Directors after login. From here, ADs can initiate new surveys, view/edit 

existing entries, or check the status of forests. 

 

Welcome Screen Overview 

 

 

Key Actions 

1. New Entry 

• Add a new compartment-level survey (spatial/non-spatial data).  

• Click "+ New Entry". 

• A form will apear as shown below. 



 

 

 

 

Data Entry Form - Screen Overview 1 

 
 

• Zone: Select from dropdown (pre-filled based on user’s district, e.g., "Northern Zone"). 

• Division: Verify auto-filled division (e.g., "Murree"). 

• Gross Area (Acres): numerical value only (e.g., 150) - Must be > 0. 

• Range/Sub Division: Verify auto-filled (e.g., "Kotli Sattian"). 

• Circle: Verify auto-filled circle (e.g., "Rawalpindi"). 

• Forest Type: Verify auto-filled (e.g., "Coniferous", "Scrub", "Riverine"). 

• Forest Name: Click dropdown and select a forest (e.g., "Kashmir Point"). 

Note: If missing, contact DBA or Lead to add. 

• Officer Name: Enter the name of the surveying officer (e.g., "Ali Raza"). 

Data Entry Form - Screen Overview 2 

 

• Compartment Number: Select from dropdown (e.g., 7/MF). 

If unavailable, choose "Others" and manually enter the number (e.g., 8/MF-new). 

• Planted Area (Acres): Enter area under active plantation (e.g., 120). 



 

 

• Plantable Blank Area (Acres): Enter area suitable for future planting (e.g., 30). 

• Blank Area (Acres): Enter non-plantable area (e.g., 50). 

• Unplantable Blank Area (Acres): Enter permanently unusable area (e.g., 20). 

• Total Area of Compartment (Acres): Verify the sum of all sub-areas. 

• Navigation: 

o "Previous": Returns to Step 1 (Basic Information). 

o "Next": Proceeds to Step 3 (only enabled if validation passes). 

 

Data Entry Form - Screen Overview 3 

 
 

Section 1: Species Planted 

Add Species 

o Click "Add Species" to add a new species row. 

o For each entry: 

▪ Species Name: Type Species name (e.g., "Chir Pine"). 

▪ % Coverage: Enter percentage (e.g., 70%). 

▪ Remove: Click bin icon to delete incorrect entries. 

 

Example: 

Species Name % Coverage 

Kail 60% 



 

 

Deodar 40% 

 

Section 2: Plantation Year 

• Enter year range (e.g., 2006-2010) OR 

• Individual years separated by commas (e.g., 2006,2010). 

 

Section 3: Source of Irrigation 

Select Sources: 

• Click "Choose..." → Select from dropdown (e.g., "Rainfed", "Canal"). 

• Selected items appear under "Selected Irrigation Sources". 

 

Section 4: Forest Density: Enter percentage (e.g., 85%). 

Section 5: Funding & Records 

Plantation Funding Scheme: 

• Select scheme (e.g., "Rehabilitation"). 

Record Availability: 

• Choose status (e.g., "Yes", "No"). 

 

Uploading Compartment Boundary (Critical Step) 

1. Click "Upload CPT Boundary": 

• A modal window appears (see below 

screenshot). 

2. Upload Zipped Shapefile: 

• Click "Choose File" → 

Select .zip containing: 

▪ Mandatory 

files: .shp, .shx, .dbf, .prj. 

• Click "Open". 

3. Verification: 

• System auto-checks: 

▪ File format validity. 

• If errors occur: Reupload corrected files. 

4. Success: 

o Boundary displays on map preview. 

o Proceed to "Close". 

 

• Navigation & Validation 

o Previous: Returns to Step 2. 

o Submit Next: Final review before submission and proceed to “Next” to upload feature boundaries. 

 

Troubleshooting 

❌ Upload Errors: 

• Ensure zipped file contains all required components. 



 

 

• Check CRS (Coordinate Reference System) matches project standards (e.g., WGS84). 

❌ Species % Mismatch: 

• Total coverage should ideally sum to ~100%. 

 

Pro Tip: Carefully see: 

   Zipped shapefile contains: .shp, .shx, .dbf, .prj 

   Boundary matches compartment location 

   Species % totals are realistic 

 

Uploading Spatial Features & Final Submission 

Submit additional spatial data layers and complete compartment survey. 

 

Upload Features Shapefile Screen 

 
 

Uploading Spatial Data Layers 

A. Built-up Structures 

• Purpose: Mark buildings/structures within the compartment. 

• Action: 

1. Click "Upload Built-up Structures". 

2. Select zipped shapefile (.zip containing .shp, .shx, .dbf, .prj). 

3. Verify preview on map. 

B. Encroachments 

• Purpose: Document illegal land occupations. 

• Action: 

1. Click "Upload Encroachments". 

2. Upload zipped shapefile with boundary polygons. 

3. Add remarks if needed (e.g., "Encroachment since 2015"). 

C. Linear Features 

• Purpose: Add roads, streams, or fences. 

• Action: 



 

 

1. Click "Upload Linear Features". 

2. Upload line/polyline shapefiles. 

 

 

Final Validation 

• System Checks: 

o All shapefiles align with compartment boundaries. 

o No file corruption (valid formats only). 

• Errors: 

o   Misaligned Layers: Adjust coordinates or reproject files. 

o   Missing Files: Rezip with all components. 

 

Submission Process 

1. Zipped shapefile must be exported from provided GDB for builtup structure, encroachment and 

linear feature files. 

2. Review: Ensure all data layers are correctly displayed on the map. 

3. Click "Submit Shapefiles" to finalize. 

4. On successful submission page will be redirected to “Welcome Page” 

 

Troubleshooting 

Issue Solution 

Shapefile misalignment Reupload with correct CRS (e.g., EPSG:4326). 

Submission failure Check internet connection; retry. 

 

IMPORTANT NOTE: Data Preparation Guidelines & GeoDatabase Processing in ArcMap 

 

Note: The system uses pre-configured geodatabases with defined domains to standardize feature categories and 

attribute values. To ensure data consistency: 

 

• Do Not Modify Geodatabase Structure: 

o Domains: Pre-set values (e.g., forest types, species names) cannot be altered. 

o Schema: Field names, data types, and relationships are fixed. 

 

• Workflow for Data Collection: 

Step 1: Digitize Features 

o Draw boundaries/features directly in the provided geodatabase. 

Step 2: Populate Attributes 

o Use dropdowns (domain values) for fields like "structureType", “encType” & “linearType”. 

o In case of missing feature type in the dropdown, choose others and write that type in “Others” field. 

Step 3: Validate Data 

o Cross-check attribute tables for errors before export. 

o After exporting into shapefile calculate other values from “Others” field into type field.  

Step 4: Export & Upload 



 

 

o Convert to zipped shapefile (include .shp, .shx, .dbf, .prj). 

o Upload via the web portal. 

System Checks: The web portal validates shapefile fields against geodatabase standards. 

Rejection Risk: Tampering with domains/schema will cause upload failures. 

Key Reminders: 

   Always: 

• Use the original geodatabase as your starting point. 

• Verify data before exporting to shapefile. 

  Never: 

• Edit domain values or field names in the geodatabase. 

• Upload shapefiles created from scratch (missing domain checks).  

 

1. Add geodatabased from the shared folder and digitize each individually based on compartment features. 

 

 
 

2. The attribute structure of all three geodatabases are as below: 

 



 

 

   
 

 

3. Below are the snapshots of dropdowns of feature types from each geodatabase of features. 

 

 
 

 
 



 

 

 
 

4. Digitized features example: 

 

 
2. Viewing & Managing Compartment Entries 

Welcome Screen Overview – View Entry 

 
 

Features: 

• Filter: Select specific forests from "Forest" dropdown (default: "All Forest"). 



 

 

Column Description 

Compartment No. Unique ID (e.g., 94/PF). 

Forest Name Parent forest (e.g., " Karlot PF"). 

Status Waiting for Assignment, Returned by QC, Returned by DFO etc. 

Observations If returned with observations 

Actions Edit/View options (see below). 

 

Action Buttons 

• "View Observations" (For Returned Entries): 

▪ Click to see QC  and DFO feedback (e.g., "Boundary misalignment in shapefile"). 

• "Edit": 

▪ For "Returned" Entries: Correct data and resubmit. 

Scenario: Compartment rr (Baraholer Forest) was returned by QC. 

▪ Steps: 

1. Click "Edit" next to the entry. 

2. Review QC Observations (popup appears). 

3. Make corrections: 

o Adjust spatial data (re-upload shapefiles if needed). 

o Update species percentages or other non – Spatial data. 

4. Click "Resolve Observation" and this will be forwarded back to QC or DFO. 

▪ For "Waiting" Entries: Modify draft submissions. 

Compartment List View Screen 

 
 



 

 

Key Rules 

• Editable Fields: Depends on status: 

Status Editable? 

Returned by QC Full edit access 

Waiting for Assignment Editable until assigned to QC 

• Data Locking: Once approved by DFO, contact admin for changes. 

 

Troubleshooting 

  "Edit" Button Disabled: 

• Ensure status is "Returned" or "Waiting". 

• Refresh page; contact QA Lead if issue persists. 

  Missing Observations: 

• QC may not have added proper notes; verify with your team. 

 

 

 

 

 

 

 

 

 

 

 

Editing Compartment Data (Spatial and Non – Spatial Both) 
 

Attribute Editing 

• Core Information (Non-Editable): Forest Name, Division ID, Sub Division & Officer Name. 

 

Editable Fields 

Field Rules Format 

Total Area Must equal sum of all area fields 4.00 acres 

Planted/Blank Areas ≥ 0 Numeric (2 decimal) 

Forest Density 1-100% 99 

Funding Scheme Multi-select from domains Non Developed, Khushali Bank 



 

 

Plantation Year Years/ranges separated by commas 2006-2009, 2008 

Remarks Optional notes Free text 

 

Area Validation 

• Total Area = Planted + Blank + Plantable Blank + Unplantable Blank   

 

Species Management 

• Add New Species: 

1. Click Add New Species. 

2. Enter % Coverage (ensure total ≤100%). 

 

Spatial Data Updates 

• Upload Options 
1. CPT Boundary: Re-upload corrected compartment boundary. 

2. Built-up/Encroachment/Linear Features: Replace specific feature layers. 

Requirements: 

1. Zipped shapefiles (.shp, .shx, .dbf, .prj). 

2. CRS: EPSG:4326 (WGS84). 

 
QC Observation Resolution 

• Resolve Observations: 

1. Click to view QC notes (e.g., "Boundary mismatch in NW sector"). 

2. Make corrections via attribute/spatial edits. 

3. Click Update Attributes → Resubmit to QC / DFO. 

4.  

Edit Compartment Data Screen 

 



 

 

 
 



 

 

 

Action Buttons 

Button Purpose 

Update Attributes Saves non-spatial changes. 

Upload Features Replace spatial data layers. 

Resolve Observations Mark QC / DFO issues as addressed. 

 

Example Workflow 

• Correct Areas: Adjust Planted Area from 1.00 to 1.50 → Update Total Area to 4.50. 

• Add Species: Insert "Blue Pine" at 20% coverage. 

• Fix QC Flags: Re-upload boundary file to resolve alignment issues. 

• Submit: Click Resolve Observations to notify QC / DFO. After resolving will be redirected to view page. 

 

3. Completion of Forest Status 

Welcome Screen Overview – Status Update 

 

Steps to Mark Forest as Completed 

• Verify Data: 

1. Confirm the count of compartments surveyed to mark forest survey as completed. 

2. Initiate Completion: 

3. Click "Completed" button. 

• Confirmation: 

1. System displays: "Are you sure you want to mark this survey as completed?", click “Yes”. 

 

 

 

 



 

 

 

 

Completion Status Screen 

 

 

QA Lead Module 

Dashboard for QA Leads to monitor and assign forest surveys to QC team members. 

 

Welcome Screen Overview – QA Lead  

 
 

Navigation Options 

1. View Coming Entries 

• Purpose: Review newly submitted forest compartments from ADs that require QC assignment. 

2. View Status 

• Purpose: Track progress of assigned surveys across QC team. 

• Displays: 

o Compartments Pending QC: Count and forest names. 



 

 

o Under Review: Currently being analyzed by QC. 

o Returned for Corrections: Flagged issues needing AD action. 

1. Assigning Forests to QC Team 

Key Columns 

Column Action 

Unique ID System-generated tracking code 

Forest Details Zone, Division, Forest Type  

Assigned To Dropdown to select QC officer 

Actions Click Assign to confirm 

Workflow 

1. Select QC officer from Assigned To dropdown. 

2. Click Assign → Confirmation popup appears. 

Rules 

• One forest can be assigned to only 1 QC officer at a time. 

• Reassignment requires QA Lead approval. 

 

Data Entry Tracking Form Screen 

 
 

2. Tracking Survey Progress 

Key Fields 

Field Purpose 

CPT Survey Count Total compartments in forest 



 

 

Field Purpose 

Assigned Date When QC received the task 

Survey Status Completed/Invalid 

Verification Status 
Count of QC Pending/QC Passed/ QC Observations 

compartments 

 

Status Interpretation 

Status Meaning Next Step 

QC Pending Under review by QC Monitor progress 

QC Passed Approved; moves to DFO No action needed 

 

Troubleshooting 

  Cannot Assign Forest? 

• Ensure forest isn't already QC Passed or assigned to another officer. 

  Missing QC Officers in Dropdown? 

• Confirm officers are active; contact admin if missing. 

 

Example Workflow 

1. QA Lead filters for Northern Zone → Assigns 3 forests to QC Officer Ali. 

2. Next day, checks View Status: 

o 2 forests QC Passed. 

o 1 forest Returned with observation "Boundary mismatch". 

 



 

 

Forest Assignment by Lead Screen 

 
 

QC of Spatial and Non - Spatial Data Module 

Interface for Quality Control (QC) personnel to review and validate forest compartment data submitted by ADs. 

 

 
 

Navigation Option 

View Entries 

• Purpose: Access all forest compartments assigned to you for verification. 

• Displays: 

o List of compartments grouped by forest. 

o Key status indicators (Pending, Returned, Approved). 

 



 

 

1. Reviewing Assigned Compartments 

Assigned Forests QC List Screen 

 
 

Key Features 

• Filter: Use dropdowns to sort by Forest/Division/Status. 

• Status Indicators: 

o QC Pending: Awaiting verification 

o Resubmitted after Correction to QC: Returned after AD corrections 

Actions 

• Click "View" to inspect compartment details view page. 

 

 

2. In-Depth Compartment Verification Process 

Detailed interface for QC officers to validate spatial/non-spatial data and manage review outcomes. 

Data Validation Sections 

Area Calculations 

Field Value (acres) Validation Rule 

Total Area 14.00 Must equal sum of below 

Planted Area 1.00 - 

Blank Area 1.00 - 

Plantable Blank 11.00 - 

Unplantable Blank 1.00 Sum Check: 1+1+11+1 = 14    



 

 

Ecological Data 

• Forest Density:  

o Verify against satellite imagery. 

• Plantation Year:  

o Cross-check with historical records. 

• Funding Scheme: 

o Ensure alignment with domain values. 

 

Species Composition 

Species % Coverage 

ddd 55% 

tit 55% 

Rule: Total ≤100% (Current: 110% → Flagged). 

 

Spatial Data Verification 

Required Steps: 

1. Download Files: 

o Boundary, Built-up, Linear Features, Encroachments (GeoJSON). 

2. GIS Validation: 

o Open in QGIS/ArcMap to: 

▪ Check boundary topology (no gaps/overlaps). 

▪ Verify feature alignment (e.g., structures within bounds). 

3. Attach Evidence: 

o Upload screenshots of issues (e.g., "Species % exceeds 100%" or boundary 

misalignment). 

 

GIS Validation Cheat Sheet for QC Officers 

Tools Needed: QGIS/ArcMap, Satellite Imagery (Google/Bing) or Geometry Checker Plugin / Toplogy 

 

Boundary Checks 

Check Method Acceptance Criteria 

Alignment Overlay boundary on satellite imagery ≤5m deviation from actual forest edge 

Topology Use QGIS "Geometry Checker" No gaps/overlaps with adjacent compartments 

Area Calculate in GIS (Ha) Must match submitted "Total Area" (±1%) 

 

Feature Validation 

Add basemap on GIS Software to verify Spatial Boundaries as well. 

Feature Validation Rule 



 

 

Built-up Structures Must be within compartment boundary 

Encroachments Verify with revenue records if disputed 

Linear Features (roads/streams) Check connectivity to external networks 

 

Attribute-Spatial Cross-Checks 

• Forest Density: Compare with NDVI maps (if available). 

• Species %: Ensure planted areas align with species distribution maps. 

 

Quick QGIS Steps 

1. Load Files: 

Download → Layer → Add Layer → Add Vector Layer (select GeoJSON)   

2. Enable Satellite Imagery: 

Open ArcMap → Add Google Satellite or any other basemap. 

3. Run Geometry Checks: 

Vector → Geometry Tools → Check Validity   

 

 

 

Common Errors & Fixes 

Observed errors and possible fixes may be added in text format in observations so that AD can view and 

rectify accordingly.  

Error Solution 

Boundary gaps Request AD Snap vertices to adjacent compartment 

Species % >100 Request AD to revise species table 

Misaligned features Request AD to Re-digitize with GPS points 

 

Visual Guide 

Include annotated screenshots of: 

1. Valid vs. Invalid Boundaries (highlighting gaps/overlaps). 

2. Feature Misalignment Example (e.g., building outside boundary). 

 

       Pro Tip: Carefully see: 

   Keyboard Shortcuts: 

• Ctrl+Click to measure distances in QGIS. 

• F7 to toggle topology editing. 

   Documentation: 

• Always save validation screenshots as [CompID]_[Date]_[Issue].jpg 

 



 

 

Action Buttons 

Button Function 

Approve Submit to DFO if all checks pass 

Return to AD Send back with observations  

Download All Export full dataset for offline review 

Adding Observation Screen on Click of Return to AD 

 

Common Observations Format 

• Issue: Species % totals 110% (exceeds 100%)   

• Location: Species table   

• Evidence: [Attach screenshot]   

• Action Required: Adjust percentages or remove redundant entries.   

 



 

 

Compartments Verification Form Screen 

 
 

Workflow Example 

1. QC downloads boundary → finds 5% overlap with adjacent compartment in QGIS. 

2. Adds observation: 

Issue: Boundary overlap with CPT-CCF (5% area)   

Evidence: [Overlap_Screenshot.jpg]   

3. Clicks "Return to AD" → Status changes to Resubmitted. 

Key Rules 

   Mandatory: GIS validation before approval. 

      Edits: QC can only add observations, not modify data directly. 

       Turnaround: Resolve within 5 working days (system alert after 3 days). 

 

DFO Forest Compartment Review Module 

Allows District Forest Officers to monitor approved compartments, view summaries, and address escalated 

issues. 



 

 

 

Navigation Option: 

• View Entries: Access all QC-approved forest compartments for final review. 

 

DFO Welcome Screen 

 
 

1. Reviewing Forest Entries Interface 

Forest Summary Table 

Column Description DFO Action 

Zone/Circle Administrative boundaries Filter/sort data 

Forest Area Total acreage 
Verify against GIS 

calculations 

Compartments 

Count 

Number of sub-units / 

Compartments 
Check completeness 

Actions View button Inspect details 

Troubleshooting 

  Area Mismatch? 

Recalculate in GIS; escalate to AD through adding observation if systemic error. 

  Missing Compartments? 

Verify number of compartments and add observation if surveys are incomplete. 



 

 

View Entries Interface Screen 

 
 

2. Reviewing Forest Entries in Detail and Viewing and Adding Observations 

Review forest-wide summaries, inspect compartment details via interactive map, and flag issues. 

Forest Summary Section 

Field Verification Rule Example Value 

Gross Area Cross-check with sum of compartments 1615 acres 

Forest Density Match against satellite imagery (NDVI) 55% 

Encroached Area Validate with revenue records 147,834.17 kanal 

 

Interactive Map Features 

A. Spatial Layers 

• Forest Boundary (Outer polygon) 

• Compartment Boundaries (e.g., ccc111) 

• Feature Layers: Built-up, Encroachments, Linear Features 

 

B. Popup Details 

Click any compartment to see: 

Attribute Example Value 

Area 4 acres 



 

 

Attribute Example Value 

Plantation Year 2006-2009 

Funding Scheme Non Developed, [...] 

Species Data None (Highlights missing data) 

Forest Summary – Spatial and Non – Spatial Data of Forest, Compartments and Features Screen 

 

Adding Observations 

Step 1: Access Compartment List 

• Click "View Compartment List to Add Observations". 

• Dialog appears with: 

o List of all compartments. 

o Buttons: View Observations / Add Observation. 

Step 2: Flag Issues 

1. Select compartment (e.g., ccc111). 

2. Click "Add Observation" → Fill: 



 

 

o Issue Type: Dropdown (e.g., "Encroachment Discrepancy"). 

o Description: F-ree text (e.g., "147,834 kanal encroachment missing in revenue records"). 

o Attach Evidence: Upload GPS points/screenshots. 

3. Submit: Routes to AD for action. 

 

Adding and View Observation Through Button Dialogue 

 

Adding Observation Through Buttons 

 

 

Example Workflow 

1. DFO clicks Shahdara Forest boundary on map. 

2. Notes ccc111 has no species data → Clicks "Add Observation". 

3. Submits: "Species survey missing per Compartment ccc111." 

4. Compartment reverts to AD for correction. 

 



 

 

 

DFO Forest Verification: Map-Based Workflow 

Key Features: 

• Dynamic boundary color-coding for observation status 

• Direct observation management from map popups 

• Two-way sync between list view and map 

 

Visual Indicators on Map 

Boundary Color Status 

Green Approved (no issues) 

Red Open observation(s) 

Example: 

• Compartment ccc111 turns red after adding observation. 

Forest Summary Screen after Adding Observation 

 
 



 

 

 

 

Compartment Popup on Map with View Observation Button if added 

 
 

Observation Popup Interface 

• Timestamp: 6/26/2025, 4:06:21 PM 

• Status Badge: Open/Resolved 

• Screenshot View: A screenshot will be displayed if added while adding observation. 

Compartment Observation Popup on Map 

 
 

Troubleshooting 

  Color Not Updating? 

• Refresh map layer (F5). 

• Clear browser cache. 

 



 

 

Note:  If all approved DFO can click on the button at Bottom Right Corner to Approve Forest and then that forest 

with all its compartments will be locked. 

 


